Install Adobe Flash [Frash] on iPhone 4 Easily!

by Jeffry on August 9, 2010

Comex Frash port for accessing Adobe flash content on iPad, iPhone and iPod touch has now been ported to the iPhone 4 and other iOS 4 devices. Frash which was ported into iPad few weeks back, has now been ported into jailbroken iPhone 4 after the guys over Grant Pannell site managed to compile an iPhone 4 version of Flash. This pre-alpha build of Frash supports all armv7 devices including iPhone 3GS, iPod Touch 3G, iPad, iPhone 4 iOS4 and iPad 3.2.x.

iphone-4-flash

Those who don’t know Frash port by Comex lets you run Flash10.1 programs natively in the MobileSafari browser allowing you to play games and other animations on Apple iPad. If you are looking to access flash enabled sites to view animation and play flash games on your iPhone 4, then follow the step by step instructions listed below. All you need to do is add ‘repo.benm.at’ repo from Cydia.

How to install Flash 10.1 on Jailbroken iPhone 4

Step 1: Jailbreak your iPhone 4, iPod Touch 3G and iPad 3.2.x with JailbreakMe.

Step-2: Start ‘Cydia’ on your jailbroken iPhone 4 iOS 4.0.1 springboard.
Step 3: Select ‘Manage’ tab at the bottom of your iPhone screen and then select ‘Sources’.

Step 4: Select ‘Edit’ and then select ‘Add’. Now enter a URL source. Type ‘repo.benm.at’ and select on ‘Add Source’. Once Cydia has added the source click on ‘Return to Cydia’ button.

FrashoniPhone4

Step 5: Once the installation is completed. Search for ‘Frash’ in Cydia and install it.

FrashoniPhone

Step 7: Reboot your iPhone.

Voila! You have now successfully installed Adobe Flash 10.1 on Jailbroken iPhone 4 successfully!

You might also like to check out:

Blog Widget by LinkWithin
  • Radio rocker

    I just have one question about this cause “jailbreak” sounds kinda shifty to me. Is this even legal and could I get in any type of trouble for it?

  • BELLA

    Hi..I tried installing frash by doesn’t work on the new iPad jailbroken? On 5.1.1. Keep getting an error food abort? Can anyone pls help..thanks in advance

  • http://profile.yahoo.com/UUVN7J3WKYYV6LFV3OJMSRUKP4 Sally

    oaoaoao my ipod touch 4 with Jailbreak but iOS 5 so it doesn’t work
    please help me

  • http://www.flashgamedownloader.com/ download flash games

    Hi,

    I really so interested for installing Adobe Flash games on iPhone 4, I liked your article guys and explaining style for installing Adobe Flash games on iPhone 4.

    Thanks guys for the help.

  • Jsyarib

    Hi there.. I tried it but unfortunately i got ths msg:
    Note: The requested modifications cannot be applied due to required dependencies or conflicts cannot be automatically found or fixed.
    Pls kindly advice tq so much!

    • I help you!

      Hi, frash only work on iphone 3gs, iphone 4, iphone 4s and ipod touch 4, any device without a camera doesnt work

  • tony garcia

    i got an error c.43 food?

    anyone have any idea

    • Chris

      Yes, it means that your phone is one of two things, extreemly behind on updates or too new of updates.

  • UNKNOWN

    Thanks A HEAP ;)

  • Shikintan

    can my i phone 3gs download flash 10.1 too? can it play evony free forever after downloading the flash 10.1 ??

  • Soletwosole

    Works fine for me too! I experienced the same problem with Hulu.com, but who cares? I got flash on the other sites I visited!

  • Bigduckbandit

    worked fine for me

  • Flying13

    I went to hulu.com on safari and it loads, but then closes the entire browser and you end up on the home screen. I then went to it again and it stayed open. I searched for something on the hulu search and AGAIN, it went to the home screen…what’s going on? Did the frash not install properly??? Are any of you having this problem? I also tried opening random videos from hulu and a screen pops up on my iphone and says, “Cannot open page Safari cannot open the page because the address is invalid”. Ideas? Suggestions? Please help!

  • Topi

    Work like a charm.
    Thanks Comex =))

  • http://www.androiddevelopmenttalk.com Rockcruze

    Working fine for not ..lets check in for some time

  • lololol

    just so you know if you get a dependency error then it wont work and you dont have the new processer (armv7) which is included in ipt3g iphone 3gs and 4

  • HArchH

    Following these instructions, it Frash fails to install for me. Perhaps because I'm trying on an iPhone 3G (not an “S”).

  • Thk1679

    just installed it but didnt work? anyone have any idea

    • Jakekuznar5

      do u have mobile cinema installed or something in your internet browser installed form cydia that adds to the internet browser cuz i had mobile cinema and i had to unistall that to make frash work

  • http://twitter.com/Brian_Blank Brian Blank

    I went through the step-by-step instructions on Gadgets-DNA.com, and this photo — http://bit.ly/aVTYvQ — shows the error message that I got while trying to install Frash on my 3G iPhone, running iOS 4.01 and jailbroken. Suggestions??

    • Lacrossplayereht

      I believe Frash only supports Firmware 4.0 not 4.0.1

  • Talhah

    Just did it, OMFG Steve Jobs was making a big deal over this? f*cking idiot.

    Like Darrin said, it's easy to install.

  • Phil9t

    installing it know hope it works

    • Phil9t

      now not (know) to much excitement !!!

  • DarrinSearancke

    Did it. Works like a charm! Who knew Flash on your iPhone would be so easy!?!

    • Bigduckbandit

      worked fine for me

Previous post:

Next post:

Gadgets DNA | About us |  Copyright Policy |  Privacy Policy |  Disclaimer |  Subscribe us |  Contact us |  RSS Feed |  Sitemap